Ayuda reparación de pcb Star Force

Gabinetes, PCBs, mantenimiento, etc
Reglas del Foro
Las reglas son muy sencillas. Por favor abstengase de postear acerca de copias piratas, descargas ilegales, enlaces, etc. Lo mismo aplica a material ofensivo, es decir, fuera de contexto o inapropiado.

Todo lo demás está permitido siempre y cuando no se esté ofendiendo a alguien más de manera directa e intencional. Por lo mismo no se permite insultar a los demás usuarios.

Cualquier violación a éste reglamento, resultará en un ban permanente.
Responder
wolf3
Mensajes: 2
Registrado: Mié Nov 29, 2017 4:44 pm

Ayuda reparación de pcb Star Force

Mensaje por wolf3 » Mié Nov 29, 2017 5:08 pm

Buenos días;
Tengo una placa Star force que quiero recuperar y aunque arranca perfectamente y hace el juego exhibición, admite créditos,... etc pero tiene un fallo en las figuras en movimiento.
Cuando aparecen tanto la nave del jugador, como los muñecos enemigos en movimiento, todos ellos salen perfectamente definidos pero dentro de una banda de color horizontal de lado a lado de la pantalla que se mueve a la vez del muñeco o nave. He revisado la 2 ram 2114 que lleva para este cometido y las he cambiado pero no consigo solucionarlo. Parece que las 3 memorias de figuras que lleva, están bien ya que la definición de los muñecos y nave, es buena. Creo que la avería está en la zona alrededor de esas memorias o las ram dinámicas, pero no encuentro que señal puede estar mal, incluso con el osciloscopio, ya que no tengo el esquema electrónico de la placa.
Agradecería cualquier ayuda de otro miembro al que pueda haber ocurrido algo similar o bien conozca esa placa PCB, tenga el esquema electronico y pueda saberlo.
Gracias de antemano.
Saludos
Adjuntos
IMG_20171120_175154.jpg
Ahí aparecen las bandas de color horizontales que contienen las figuras en movimiento.
IMG_20171120_175200.jpg
IMG_20171120_175224.jpg

Avatar de Usuario
Artemio
Site Admin
Mensajes: 2162
Registrado: Lun Ago 06, 2012 5:04 pm
Cuenta de Twitter: Artemio
Ubicación: México
Contactar:

Re: Ayuda reparación de pcb Star Force

Mensaje por Artemio » Jue Nov 30, 2017 9:34 am

Seguramente es la parte de video que hace la mezcla de los gráficos, ya que te está borrado toda la horizontal.

Tienes que hacer lo básico: Revisar todos los TTLs, comparando con las tablas de valores lógicos en el osciloscopio. Así com todas las señales de control de RAMs y ROMs.
"But for those lurking around the fringes of the masses... there is always hope for their seduction."

The Policenauts Translation Project
240p Test Suite

wolf3
Mensajes: 2
Registrado: Mié Nov 29, 2017 4:44 pm

Re: Ayuda reparación de pcb Star Force

Mensaje por wolf3 » Jue Nov 30, 2017 1:50 pm

Muchas gracias por tu respuesta!!
A qué tablas de valores lógicos te refieres? Al mirar el esquema de cada TTL y ver si cumple ell valor lógico de cada puerta o dispositivo?
Pero con señales de MHz lo veo complicado.

Avatar de Usuario
Artemio
Site Admin
Mensajes: 2162
Registrado: Lun Ago 06, 2012 5:04 pm
Cuenta de Twitter: Artemio
Ubicación: México
Contactar:

Re: Ayuda reparación de pcb Star Force

Mensaje por Artemio » Vie Dic 01, 2017 1:02 pm

Justo es hacer eso. Generalmente es que funciona o falla por completo, no tienes que comparar cada pulso con un analizador lógico.
"But for those lurking around the fringes of the masses... there is always hope for their seduction."

The Policenauts Translation Project
240p Test Suite

Responder