Reparacion CPS1 A board Sin sonidos FX

Gabinetes, PCBs, mantenimiento, etc
Reglas del Foro
Las reglas son muy sencillas. Por favor abstengase de postear acerca de copias piratas, descargas ilegales, enlaces, etc. Lo mismo aplica a material ofensivo, es decir, fuera de contexto o inapropiado.

Todo lo demás está permitido siempre y cuando no se esté ofendiendo a alguien más de manera directa e intencional. Por lo mismo no se permite insultar a otras personas.

Cualquier violación a éste reglamento, resultará en un ban permanente.
Avatar de Usuario
Deadmanrrg
Mensajes: 56
Registrado: Lun May 30, 2016 11:53 am
Cuenta de Twitter: @Deadmanrrg
Ubicación: Guadalajara
Contactar:

Reparacion CPS1 A board Sin sonidos FX

Mensaje por Deadmanrrg » Jue Mar 21, 2019 7:56 pm

Que tal, como están todos?

Tengo un problema haber si me pueden ayudar: Tengo un Street Fighter Hyper Fighting que tiene un problema de sonido en la placa "A", lo que pasa es que emite sonido pero solo una parte de la música, las voces así como golpes y efectos de sonido no los reproduce.
Porque estoy seguro que es la placa A? Porque tengo otro Street (World Warrior) y cuando cambio la placa de Hyper Fighting a la placa "A" del World Warrior, esta le funciona todo el audio sin problemas.

Cambié el Z80 creyendo que ese era el problema pero no es así, revise todas las pistas y se ven bien, no parece que ninguna este rota, ademas de que el amplificador también funciona.

Que creen que pueda ser? ya que le he buscado también viendo si algo esta desolado y no es así.

Espero me puedan orientar.

Muchas Gracias.

Avatar de Usuario
Artemio
Site Admin
Mensajes: 2519
Registrado: Lun Ago 06, 2012 5:04 pm
Cuenta de Twitter: Artemio
Ubicación: México
Contactar:

Re: Reparacion CPS1 A board Sin sonidos FX

Mensaje por Artemio » Jue Mar 21, 2019 9:19 pm

Para futura referencia: si se escucha algo de sonido, no es el Z80.

El Z80 controla al YM2151 que reproduce la música FM y al OKI6295 que reproduce todos los sonidos digitalizados.

Evidentemente tu problema está por ese lado. Tendrás que revisar desde la entrada de datos del OKI6295, a sus OPAMPs y de allí al circuito de mezclado antes del amplificador.

Puedes armare un probador como el que muestro en este video.

https://youtu.be/uEVPAEPgU7E?t=1875
"But for those lurking around the fringes of the masses... there is always hope for their seduction."

The Policenauts Translation Project
240p Test Suite

Avatar de Usuario
Deadmanrrg
Mensajes: 56
Registrado: Lun May 30, 2016 11:53 am
Cuenta de Twitter: @Deadmanrrg
Ubicación: Guadalajara
Contactar:

Re: Reparacion CPS1 A board Sin sonidos FX

Mensaje por Deadmanrrg » Vie Mar 22, 2019 12:37 am

Gracias Armenio, revisare detenidamente esos dos chips de sonido.
Sobre lo del probador, no tengo idea de como se hace ya que no tengo el conocimiento necesario para armar un probador así, ni siquiera sabria como usarlo, aunque lo muestras en el video, no sabría ni por donde empezar.

Otra idea que se me ocurre es quitarle el YM2151 a una placa para probarla con la otra, si no funciona cambiar el OKI6295 también y asi ver si uno de esos 2 chips son el problema.

Gracias de nuevo.

Avatar de Usuario
Artemio
Site Admin
Mensajes: 2519
Registrado: Lun Ago 06, 2012 5:04 pm
Cuenta de Twitter: Artemio
Ubicación: México
Contactar:

Re: Reparacion CPS1 A board Sin sonidos FX

Mensaje por Artemio » Vie Mar 22, 2019 1:15 am

Cómo te mencioné el Yamaha hacé la música, así que no sería el problema según tu descripción.

El ideal es que aprendas a usar las herramientas. Igual yo no sabía, y he aprendido. Así no trabajas a ciegas.

Si te interesa acá estamos para ayudar a aprender
"But for those lurking around the fringes of the masses... there is always hope for their seduction."

The Policenauts Translation Project
240p Test Suite

Avatar de Usuario
Deadmanrrg
Mensajes: 56
Registrado: Lun May 30, 2016 11:53 am
Cuenta de Twitter: @Deadmanrrg
Ubicación: Guadalajara
Contactar:

Re: Reparacion CPS1 A board Sin sonidos FX

Mensaje por Deadmanrrg » Vie Mar 22, 2019 10:35 am

Tienes razón Artemio, si no aprendo, no podré saber cómo abordar los problemas futuros.
Voy a conseguir el material para hacerlo y les voy preguntando cada que me atore en algo.

Cuando tenga todo listo hare las pruebas correspondientes y les actualizo para ver cómo me fue.

Muchas gracias.

Avatar de Usuario
Artemio
Site Admin
Mensajes: 2519
Registrado: Lun Ago 06, 2012 5:04 pm
Cuenta de Twitter: Artemio
Ubicación: México
Contactar:

Re: Reparacion CPS1 A board Sin sonidos FX

Mensaje por Artemio » Vie Mar 22, 2019 11:32 am

Si estaremos esperando para ayudarte. Me da mucho gusto.
"But for those lurking around the fringes of the masses... there is always hope for their seduction."

The Policenauts Translation Project
240p Test Suite

Avatar de Usuario
lugerius
Mensajes: 56
Registrado: Vie Nov 11, 2016 2:44 pm
Cuenta de Twitter: lugerius

Re: Reparacion CPS1 A board Sin sonidos FX

Mensaje por lugerius » Vie Mar 22, 2019 12:14 pm

Hola qué tal!


Con respecto a tu problema, yo tuve un problema muy similar y te puedo recomendar no desoldar nada hasta estar seguros de que es necesario.

Para iniciar tu diagnóstico de audio descarga el manual de CPS1 A board aquí . En este caso se muestra la new version, pero hay otra versión para A board conocida como old version.

En la imagen siguiente puedes ver donde se origina la señal analógica de sonidos y voces.
diagrama.png
Debes revisar lo que sale del OKI6295 en pin #36. Para eso necesitas el amplificador externo que te recomienda Artemio

Yo usé un adaptador para audífono con un cable miniplug como el de la imagen y adaptarle unas puntas como las que se muestran. Una punta debe conectarse a tierra en la PCB y la otra se usará para medir en algunos puntos específicos.

IMPORTANTE: Esto solo es para propósitos de prueba porque el acoplamiento de impedancia entre los audífonos y el OKI no es el idóneo y si se usa de manera prolongado se puede dañar el OKI

puntas.png
Conectar la punta con audífonos o la que venga del amplificador externo de pruebas al pin#3 del 5218A ubicado en 11B y ahí debes escuchar los sonidos faltantes que vienen de la pata 36 del OKI.
5218.png
Si no los escuchas, probablemente tengas un problema en el OKI (verificar que tenga reloj en pin5) ó al recibir los datos de la placa B.
Revisa continuidad entre ambas placas siguiendo el pinout siguiente:
cn1.png
cn1.png (70.19 KiB) Visto 657 veces
esta información fue publicada en https://wiki.arcadeotaku.com/w/CPS1_Repair_Logs

Por otra parte si al conectar la punta con audífonos al pin#3 del 5218A ubicado en 11B escuchas los sonidos faltantes, entonces ahora mide el pin7 de ese mismo chip, si ahí ya no escuchas nada, entonces el problema está en la circuitería alrededor del 5218A ubicado en 11B o el propio 5218A. Revisa las resistencias R44(1K), R45(10K) y capacitor C16 (393 = 39nF). También debes revisar R38(10K) y C12(182). Si aún no tienes audio en la salida #7 cambia el 5218A.

Si esto no soluciona el problema general de sonidos faltantes es posible que la falla incluya otro componente en la siguiente etapa de la mezcla de sonidos.
mezcla.png
Ahora revisa el capacitor CC10 (10uF) si tiene daño físico notable debes reemplazarlo o si tienes duda de su funcionamiento , por su parte revisar R36(15K).
Yo tuve un problema similar como se puede ver en el video.



y al repararlo quedo como aquí.



Espero que esta información sea de ayuda.

Avatar de Usuario
miguelangeloorti
Mensajes: 420
Registrado: Sab Jul 25, 2015 1:59 pm

Re: Reparacion CPS1 A board Sin sonidos FX

Mensaje por miguelangeloorti » Sab Mar 23, 2019 1:03 am

Me encanto tu respuesta tu explicacion tu diagnostico esta super completo yo tengo algunas placas asi les echare un ojo bro muchas gracias por tu informacion y la ayuda que le estas dando al compañero ya que a todos nos es muy util en verdad gracias bro

Enviado desde mi SM-G955F mediante Tapatalk

Avatar de Usuario
Artemio
Site Admin
Mensajes: 2519
Registrado: Lun Ago 06, 2012 5:04 pm
Cuenta de Twitter: Artemio
Ubicación: México
Contactar:

Re: Reparacion CPS1 A board Sin sonidos FX

Mensaje por Artemio » Sab Mar 23, 2019 12:32 pm

Lo más importante es entender que esos procesos son generales y que este mismo tipo de diagnostico se hace en cualquier caso. Es importante porque cada PCB tiene problemas distintos, es muy difícil que sean idénticos.

Lo ideal es que todos entendamos como se llega a estas conclusiones. Y como funciona el circuito de manera general. Todo comienza con los voltajes y relojes, de allí a los buses de datos y direcciones, de allí RAMs y ROMs. Luego siguen, en el caso del audio, los sintetizadores y ADPCM, de allí los opamps, el mezclado y finalmente el amplificado.

Eso aplica a casi cualquier PCB.
"But for those lurking around the fringes of the masses... there is always hope for their seduction."

The Policenauts Translation Project
240p Test Suite

Avatar de Usuario
lugerius
Mensajes: 56
Registrado: Vie Nov 11, 2016 2:44 pm
Cuenta de Twitter: lugerius

Re: Reparacion CPS1 A board Sin sonidos FX

Mensaje por lugerius » Sab Mar 23, 2019 10:37 pm

miguelangeloorti escribió:
Sab Mar 23, 2019 1:03 am
Me encanto tu respuesta tu explicacion tu diagnostico esta super completo yo tengo algunas placas asi les echare un ojo bro muchas gracias por tu informacion y la ayuda que le estas dando al compañero ya que a todos nos es muy util en verdad gracias bro

Enviado desde mi SM-G955F mediante Tapatalk
No hay de que, es bueno saber que a alguien más pueda servir esta información. Yo tuve el mismo problema por eso de la respuesta mas específica. Saludos Miguel Ángel.
Artemio escribió:
Sab Mar 23, 2019 12:32 pm
Lo ideal es que todos entendamos como se llega a estas conclusiones. Y como funciona el circuito de manera general. Todo comienza con los voltajes y relojes, de allí a los buses de datos y direcciones, de allí RAMs y ROMs. Luego siguen, en el caso del audio, los sintetizadores y ADPCM, de allí los opamps, el mezclado y finalmente el amplificado.
Así es. Tener interés por aprender y verlo como parte del hobby ayuda

Responder