[Reparación] Donpachi de CAVE: Derecha P1 siempre activa

Foro para archivar logs de reparación de PCBs o hardware arcade en general.

[Reparación] Donpachi de CAVE: Derecha P1 siempre activa

Notapor Artemio » Mar Oct 30, 2012 1:15 am

Pues hace unas semanas encontré una placa de Donpachi, el primer juego de CAVE, a la venta. Su precio era una fracción del precio regular de la placa, y esto se debía a una falla: La derecha del jugador 1 siempre se encontraba apretada. Todo lo demás se reportaba a la perfección. En ese momento pensé que era la placa perfecta para mí, es una placa muy cara y no la volvería a ver en un precio así. Además era muy probable que pudiera repararla, había arreglado fallas idénticas en tres placas de ese mismo período: Trigon, Simpsons y Gaiapolis. En los tres casos se trataba de un integrado TTL para multiplexar las señales de control, un 74LS257o un 74LS253.

Sin embargo no fue una subasta sencilla. La PCB cuenta con el manual y hoja de instrucciones originales, y varias personas más pujaron por ella; algunos a los que seguramente no les importaba jugar únicamente del lado del Player 2 y otros tantos que como yo pensaban repararla.

Después de la puja llegó a mis manos justo hoy. Antes que nada procedí a inspeccionarla, y como esperaba no se notaba ningún daño. El juego presentaba justo la falla descrita:

DSC_0001.JPG
Derecha siempre activa en P1


Ahora necesitaba encontrar el integrado culpable, para esto utilicé el mismo proceso que en otros casos. Buscar entre los TTLs cercanos a la zona con la punta lógica cual de ellos controlaba las direcciones. Efectivamente había 3 74LS257, y uno de ellos seguramente era el culpable. Con el diagrama del TTL en mano, busque cual de ellos me respondía a la derecha del jugador 2, ya que el ruteo de ambas señales es lo que comúnmente se conmuta con estos integrados.

DSC_0002.JPG
PCB y Punta lógica.


La punta lógica es muy útil en este caso, especialmente a falta de un osciloscopio. Su uso es también bastante sencillo, se conecta a los polos + y -, y con la punta se puede saber con un tono auditivo y un LED el estado lógico de cualquier pin en la PCB. Si se encuentra en 1 o alto, 0 o bajo o si el estado está cambiando constantemente (si hay comunicación de datos o activación de lineas). Para este caso, con saber si están en alto o bajo era suficiente, de hecho un multímetro bastaría pero sería mucho más incómodo de utilizar aún con caimanes, ya que se tendría que revisar la pantalla constantemente.

DSC_0004.JPG
74LS257 dañado. El círculo rojo indica la pata que se usa para la derecha del jugador 1


Ya habiendo identificado el chip defectuoso, procedí a desoldarlo. Siempre se debe realizar este procedimiento con cuidado y herramienta adecuada. Yo utilizo una pistola para desoldar Hakko 808 que considero mi herramienta más útil, la verdad mi habilidad con el cautín y una herramienta de succión no son suficientes para este tipo de trabajo, aunque es posible usarlas.

Aquí fue donde empezó el sufrimiento. En primer lugar, mi confiable Hakko se atascó con soldadura... y seguramente polvo, mucho polvo. Un día antes había arreglado una Scramble de 1982, y por mucho que limpié la PCB había polvo debajo de los integrados que desoldé. Este fué a parar a la boquilla de mi Hakko, y como no la limpié debidamente después de terminar; resulto en éste problema.

Al limpiar la boquilla con la herramienta indicada (un alambre con una espiral para disipar el calor), rompí dicha herramienta dentro de la pistola. Ahora se encontraba doblemente atascada. Después de batallar un rato, logré desatascarla con la ayuda de unas pinzas de presión y pude desoldar todo correctamente.

Bueno, casi todo. Al remover el integrado me di cuenta de lo que posiblemente causó el desperfecto... o tal ves yo mismo mientras desoldaba causé este problema extra exactamente en el mismo pin:

DSC_0006.JPG
Ouch


Así es, la pista que llegaba al pin 2 se encontraba completamente desprendida de la PCB.

En estos casos siempre actúo antes de analizar mucho la situación, lo cual no es necesariamente bueno. Así que decidí hacer todo con calma, sabiendo que mi reacción natural no siempre dá los mejores resultados.

Procedí a cortar unas tiras para usarlas de base, así podría remover fácilmente el TTL en caso de otra falla, y además no taparía el acceso con una base. Esto fue también para evitar desoldar de nuevo, en caso de que haya sido mi culpa el desprender la pista por calor.

DSC_0007.JPG
Tiras usadas como base.


Cuidadosamente coloqué y soldé la tira del lado opuesto al daño, para sentir que avanzaba antes de realizar la parte difícil; y pensar un poco en como proceder. Decidí soldar la pista directamente al pin, y esperar lo mejor. Con mucho cuidado, una lupa 10x y sin respirar soldé la pista a la tira sin colocarla, y acto seguido la inserté en su lugar. Lo soldé, y limpié el área. Como se puede apreciar, debido a la soldadura el pin 2 no entró al fondo... pero preferí ya no empujarlo.

DSC_0010.JPG
Tiras colocadas, con el pin soldado.


Con el multímetro comprobé que no hubiera continuidad con los pines adyacentes para evitar algún posible corto, pero no podía comprobar la continuidad desde el conector JAMMA ya que hay un arreglo de resistencias entre el TTL y el conector. Acto seguido apliqué un poco de silicón para evitar que la pista se moviese más en el futuro, y finalmente coloqué al 74LS257 nuevo en su posición.

DSC_0022.JPG


Y procedí a probarla, pensando en que haría en caso de que no funcionara. Ninguna de las ideas era muy placentera.

DSC_0011.JPG
Donpachi


No fué necesario realizar ninguna intervención más, funcionó a la perfección =)

Pero aún no me decido a probar el TTL que removí. Usualmente los saco en una pieza, pero en este caso corté tres pines para evitar levantar más pistas puesto que percibí su fragilidad. Así que no sé si la falla era el TTL y yo haya dañado la pista, o si la pista estaba dañada y el TTL si funcionaba...


EPILOGO (20 minutos después)

Si, tenía que averiguarlo. Así que reconstruí el TTL:

DSC_0023.JPG
TTL con pines reconstruídos.


Usualmente uso patitas de resistencias o capacitores, pero debido a la hora decidí usar tiras también. Procedí a probarlo en el VP-380, y efectivamente ese input se encuentra dañado. Es decir, el TTL sí estaba defectuoso...
"But for those lurking around the fringes of the masses... there is always hope for their seduction."

The Policenauts Translation Project
240p Test Suite
Avatar de Usuario
Artemio
Site Admin
 
Mensajes: 1945
Registrado: Lun Ago 06, 2012 5:04 pm
Ubicación: México

Re: [Reparación] Donpachi de CAVE: Derecha P1 siempre activa

Notapor sr_pixel » Mar Oct 30, 2012 1:21 am

:D que bien hahaha super rápido. Ahora tienes la primer placa de Toaplan y la primera de Cave :D
Está firma lo dice todo.
Avatar de Usuario
sr_pixel
 
Mensajes: 13
Registrado: Mar Ago 07, 2012 11:03 am

Re: [Reparación] Donpachi de CAVE: Derecha P1 siempre activa

Notapor bluedemonpan » Mar Oct 30, 2012 2:05 am

felicidades, ese juego se me hace muy bueno, aun que no recuerdo muy bien ya que estaba muy pequeño cuando iba a los centros recreativos jeje y cuando llegue a ir con mas conciencia el unico "grande" por no decir gigante que conocía lo cerraron al poco tiempo y ya no lo pude disfrutar mucho. Estaba en una plaza de chalco y recuerdo que tenian muchas candys :D, volviendo al tema, espero algún dia encontrarme uno de esos y no tan caro, o un Espgaluda ^¬^

PD: perdon por salirme del tema, saludos.
Avatar de Usuario
bluedemonpan
 
Mensajes: 279
Registrado: Jue Sep 13, 2012 1:55 pm
Ubicación: Mexico

Re: [Reparación] Donpachi de CAVE: Derecha P1 siempre activa

Notapor typesolid » Mar Oct 30, 2012 12:46 pm

Excelente es gratificante leer todo el procedimiento de reparación de una placa en español queda documentado para futura referencia. gracias
typesolid
 
Mensajes: 121
Registrado: Mar Ago 14, 2012 7:03 pm

Re: [Reparación] Donpachi de CAVE: Derecha P1 siempre activa

Notapor Jorgehg » Jue Nov 01, 2012 2:50 pm

Me encanta leer éste tipo de explicación pues me ayuda ver mucho mejor los componentes y sobre todo el procedimiento y como debe quedar al final =) gracias artemio
Avatar de Usuario
Jorgehg
 
Mensajes: 10
Registrado: Mar Ago 14, 2012 5:36 pm
Ubicación: Boca del Río, Veracruz

Re: [Reparación] Donpachi de CAVE: Derecha P1 siempre activa

Notapor NeoGeo Mvs » Jue Jul 03, 2014 3:34 pm

hola!! cque tipo de punta logica me recomiendas, mi atomiswave mas o menos sufre del mismo problema pero en ves de una direccion es el coin =/
Ve Galaxy Express 999 (1978) Serie Online en https://www.facebook.com/NeoGeodeAhuizo ... 570022126/ ;)
& tambien Capitan Harlock: Mugen Kidou SSX/Endless Road SSX (En su version Albator 84) 1er proyecto completo en habla hispana https://www.facebook.com/NeoGeodeAhuizo ... 013470182/ :!: :!: :!:
Avatar de Usuario
NeoGeo Mvs
 
Mensajes: 233
Registrado: Mié Ago 15, 2012 4:36 pm
Ubicación: Naucalpan de Juarez; Edo. de México

Re: [Reparación] Donpachi de CAVE: Derecha P1 siempre activa

Notapor Artemio » Jue Jul 03, 2014 10:51 pm

"But for those lurking around the fringes of the masses... there is always hope for their seduction."

The Policenauts Translation Project
240p Test Suite
Avatar de Usuario
Artemio
Site Admin
 
Mensajes: 1945
Registrado: Lun Ago 06, 2012 5:04 pm
Ubicación: México

Re: [Reparación] Donpachi de CAVE: Derecha P1 siempre activa

Notapor Eve » Mié Jul 16, 2014 2:07 am

neo geo mvs escribió:hola!! cque tipo de punta logica me recomiendas, mi atomiswave mas o menos sufre del mismo problema pero en ves de una direccion es el coin =/


Man ya pudiste resolver tu problema? Hoy uno de mis atomiswave me empezó a dar un problema así pero con el start, primero comenzó con el coin error pero después de solucionarlo, el start permanece siempre presionado, no se si tenga que ver que accidentalmente hice contacto del start con un cable de 12volts que andaba suelto y no me fijé, inmediatamente el juego se reinició pero no sabría decir si el problema fue a raíz de esto
Eve
 
Mensajes: 490
Registrado: Mar Ago 14, 2012 8:58 pm
Ubicación: Puebla, Pue.

Re: [Reparación] Donpachi de CAVE: Derecha P1 siempre activa

Notapor NeoGeo Mvs » Sab Ago 16, 2014 2:58 pm

a mi ya me paso 2 veces, tengo as 2 placas atomiswave voladas del coin 1, una porque se me fue la hebra y conecte el atomiswave con la maquina encendida (no desconecte la maquina de la corriente) y la otra mi bro le cambio el monedero electronico y cuando lo conecto se kedo pegado el coin 1, no se como solucionarlo pero obviamente es el mismo problema para ti y para mi =/
Ve Galaxy Express 999 (1978) Serie Online en https://www.facebook.com/NeoGeodeAhuizo ... 570022126/ ;)
& tambien Capitan Harlock: Mugen Kidou SSX/Endless Road SSX (En su version Albator 84) 1er proyecto completo en habla hispana https://www.facebook.com/NeoGeodeAhuizo ... 013470182/ :!: :!: :!:
Avatar de Usuario
NeoGeo Mvs
 
Mensajes: 233
Registrado: Mié Ago 15, 2012 4:36 pm
Ubicación: Naucalpan de Juarez; Edo. de México


Volver a Reparaciones

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado